3DS2 Authentication Failures Observed

Minor incident General Notifications
2023-02-28 08:00 BST · 1 day, 1 hour, 29 minutes

Updates

Resolved

We have observed 3D Secure 2 Authentication attempts to card issuers have been restored back to normal levels. We would like to take this opportunity to apologise for any inconvenience this has caused.

March 1, 2023 · 09:29 BST
Monitoring

Currently we have observed that some of the card Issuers are experiencing ongoing issues with processing 3D Secure 2 authentication caused by changes introduced in the Access Control Systems. This is resulting in a higher rate of failed authentication attempts with Visa/Mastercard cards. This is being monitored and the relevant processors have been notified.

February 28, 2023 · 15:11 BST

← Back