3DS Transactions

Minor incident General Notifications
2023-06-12 12:03 BST · 5 hours, 17 minutes

Updates

Resolved

We’re observing the elevated 3DS2 Challenge transaction fails are no longer occurring on MasterCard. Challenge flows are now fully operational. We have also observed 3D Secure 2 Authentication attempts on MasterCard have been restored back to normal levels. We would like to take this opportunity to apologise for any inconvenience this has caused.

June 12, 2023 · 17:15 BST
Monitoring

At this point Judopay’s Technology Partners confirms that the fail counts have reduced however the issue is still ongoing at MasterCard.

We continue to monitor the situation and will provide updates

June 12, 2023 · 16:09 BST
Update

At this point Judopay’s Technology Partners confirms that the issue is still ongoing at MasterCard and they are working on restoring services as soon as possible.

We continue to monitor the situation and will provide updates

June 12, 2023 · 14:58 BST
Monitoring

At this point Judopay’s Technology Partners confirms that the issue is still ongoing at MasterCard and they are working on the issue to restore the services as soon as possible.

We continue to monitor the situation and will provide updates

June 12, 2023 · 13:56 BST
Monitoring

We’ve had confirmation that MasterCard are advising of a disruption to processing affecting eCom transactions, including 3DS V2. This is urgently being worked on by them as well as our 3DS Authentication Technology partners to mitigate the service impacted from these incidents.

June 12, 2023 · 13:16 BST
Investigating

We are currently investigating 3DS transaction failures on this route and are working to resolve the issue as soon as possible.

June 12, 2023 · 13:03 BST

← Back