3DS Transactions

Minor incident General Notifications
2023-07-11 09:36 BST · 11 minutes

Updates

Resolved

We have had confirmation that the issuers Technology Partners have restored services and flows are now fully operational. We would like to take this opportunity to apologise for any inconvenience this has caused.

July 11, 2023 · 09:47 BST
Monitoring

Currently we are observing that some card issuers are experiencing ongoing issues with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with all card schemes. This is actively being worked on by the issuers 3DS Authentication & Technology partners to mitigate the service impacted from these incidents.

July 11, 2023 · 09:36 BST

← Back