3DS2 Authentication Failures Observed

Minor incident General Notifications
2023-09-12 07:01 BST · 4 hours, 46 minutes

Updates

Resolved

We have observed that Transaction processing has been restored to normal on Mastercard 3DSv2 authentication.

Also confirmation from our partners that intermittent 3DSv2 Verification request failures on the 12th September 2023 we are no longer observing any authentication failures as follows:

MasterCard since 05:30 BST - 11:12 BST

We would like to take this opportunity to apologise again for any inconvenience this has caused.

September 12, 2023 · 11:45 BST
Update

Currently we are still observing that some card issuers are experiencing ongoing issues with processing 3D Secure 2 authentication.

This is resulting in a higher rate of failed authentication attempts with Mastercard.
Issues seen with VISA have since been resolved

This is actively being worked on by our 3DS Authentication & Technology partners to mitigate the service impacted from these incidents.

September 12, 2023 · 10:37 BST
Issue

Currently we are observing that some card issuers are experiencing ongoing issues with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with Visa/Mastercard. This is actively being worked on by the issuers 3DS Authentication & Technology partners to mitigate the service impacted from these incidents.

September 12, 2023 · 09:01 BST

← Back