3DS2 Authentication Failures Observed

Minor incident General Notifications
2023-10-26 17:44 BST · 1 hour, 43 minutes

Updates

Resolved

EMV Challenge flows have been restored to normal levels.

This has been resolved by our the issuers 3DS Authentication & Technology partners.

We would like to take this opportunity to apologise again for any inconvenience this has caused.

October 26, 2023 · 19:25 BST
Monitoring

Currently we are observing that some card issuers are experiencing ongoing issues with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with Visa/Mastercard. This is actively being worked on by the issuers 3DS Authentication & Technology partners to mitigate the service impacted from these incidents.

October 26, 2023 · 17:44 BST

← Back