3DS2 Authentication Failures Observed

Minor incident General Notifications
2024-02-22 09:31 BST · 2 hours, 24 minutes

Updates

Resolved

We can confirm normal success rates on 3DS2 Transactions after a solution implemented by the card issuers 3DS Authentication & Technology partners.

The issue started at 08:45 GMT is now resolved as of 11:17 GMT.

Judopay was stable throughout as this was an external issue with an ACS provider to the UK card issuing banks, which caused an outage.

Please accept our apologies for any inconvenience this external issue may have caused.

February 22, 2024 · 11:39 BST
Update

We are observing increased success rates on 3DS2 Transactions after a solution implemented by the card issuers 3DS Authentication & Technology partners.

We continue to monitor the 3DS2 authentication rates

This issue was occurring external to Judopay

Please accept our apologies for any inconvenience this external issue may be causing.

February 22, 2024 · 11:22 BST
Monitoring

Currently we are observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Visa/Mastercard.

We have established this is occurring external to Judopay and we are aware that this is actively being investigated by the card issuers 3DS Authentication & Technology partners. This looks to be impacting their EMEA region which we’ll continue to monitor.

Please accept our apologies for any inconvenience this external issue may be causing.

February 22, 2024 · 11:00 BST
Monitoring

Currently we are observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Visa/Mastercard.

We have established this is occurring external to Judopay and we are aware that this is actively being investigated by the card issuers 3DS Authentication & Technology partners. This looks to be impacting their EMEA region

Please accept our apologies for any inconvenience this external issue may be causing.

February 22, 2024 · 09:50 BST
Monitoring

Currently we are observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Visa.

We have established this is occurring external to Judopay and we are aware that this is actively being investigated by the card issuers 3DS Authentication & Technology partners.

Please accept our apologies for any inconvenience this external issue may be causing.

February 22, 2024 · 09:11 BST

← Back