Reported Global IT Disruption

Major incident General Notifications
2024-07-19 09:56 BST · 5 hours, 36 minutes

Updates

Resolved

Reports from third-party sources indicate that the broader IT issue has been resolved. We will continue to monitor our systems closely to ensure uninterrupted service.

If you have any questions or concerns, please don’t hesitate to contact JudoPay support.

July 19, 2024 · 15:32 BST
Issue

JudoPay is aware of a global IT issue that has been reported, our systems continue to operate normally. There is no indication of any impact on JudoPay’s ability to process payments from this issue.

Our systems continue to operate normally and no issues have been identified within JudoPay that could be attributed to this incident.

July 19, 2024 · 09:56 BST

← Back