3DS2 Authentication Failures Observed

Minor incident General Notifications
2025-01-14 05:49 GMT · 8 hours, 9 minutes

Updates

Resolved

We have had confirmation that the issuers Technology Partners have restored services and challenge flows are now fully operational. We have also observed 3D Secure 2 Authentication attempts to card issuers have been restored back to normal levels. We would like to take this opportunity to apologise for any inconvenience this has caused.

January 14, 2025 · 13:58 GMT
Monitoring

We can confirm normal success rates on 3DS2 Transactions. Judopay was stable throughout as this was an external issue with an ACS provider to the UK card issuing banks, which caused an outage. Please accept our apologies for any inconvenience this external issue may have caused.

January 14, 2025 · 13:37 GMT
Issue

Currently we are observing that some card issuers are experiencing ongoing issues with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with Visa/Mastercard cards issued by Lloyds, HBoS. This is actively being worked on by the issuers 3DS Authentication & Technology partners to mitigate the service impacted from these incidents.

January 14, 2025 · 09:31 GMT

← Back