Transaction Latency
Minor incident
Full Stack Transaction Processing
JC3 - Latency
2025-05-07 20:02 BST
· 14 minutes
Updates
Resolved
May 7, 2025 · 20:17 BST
The transaction latency issues have been restored to normal thresholds. We would like to take this opportunity to apologise again for any inconvenience this has caused.
Resolved
May 7, 2025 · 20:12 BST
The transaction latency issues have been restored to normal thresholds. We would like to take this opportunity to apologise again for any inconvenience this has caused.
Issue
May 7, 2025 · 20:02 BST
We have noticed that some transactions have exceeded latency thresholds and are currently investigating the issue. We apologise for any inconvenience caused. This has been observed for the following:Nuvei
← Back