3DS2 Authentication Failures Observed

Minor incident General Notifications
2025-09-05 09:18 BST · 5 hours, 15 minutes

Updates

Resolved

We have been monitoring the 3D Secure 2 authentication issues impacting some card issuers, primarily Lloyds Bank & Bank of Scotland.

This was an external issue outside of our platform. The problem now appears to be resolved, with successful transactions being observed for these issuers.

We apologise for the disruption and thank you for your patience.

September 5, 2025 · 14:32 BST
Monitoring

We are continuing to monitor the 3D Secure 2 authentication issues impacting some card issuers, primarily Lloyds Bank & Bank of Scotland.

The situation appears to be improving, with a noticeable reduction in the authentication failure rate. This remains an external issue, and we are in contact with the issuers’ 3DS Authentication and Technology partners as they work towards full resolution.

We will provide a further update should there be significant progress.

September 5, 2025 · 14:23 BST
Monitoring

We are continuing to observe ongoing issues with 3D Secure 2 authentication affecting some card issuers, with the majority of failures seen on Lloyds Bank & Bank of Scotland.

This remains an external issue outside of our platform. We are in contact with the issuers’ 3DS Authentication and Technology partners, who are actively investigating.

At this stage, there is no further update on resolution, but we will provide the next update if new information becomes available.

We apologise for the continued disruption and thank you for your patience.

September 5, 2025 · 12:32 BST
Monitoring

Currently we are still observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Lloyds Bank & Bank of Scotland

We have established this is occurring external to Judopay and we have reached out to the issuers 3DS Authentication & Technology partners who are working with the bank issuers to resolve.

Please accept our apologies for any inconvenience this external issue may be causing.

September 5, 2025 · 11:32 BST
Issue

Currently we have observed that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Lloyds Bank & Bank of Scotland

We have established this is occurring external to Judopay and we have reached out to our 3DS Authentication & Technology partners to investigate.

Please accept our apologies for any inconvenience this external issue may be causing.

September 5, 2025 · 09:18 BST

← Back