3DS2 Authentication Failures Observed

Minor incident General Notifications
2025-10-20 11:46 BST · 3 hours, 5 minutes

Updates

Resolved

We have observed that 3D Secure 2 authentication issues have been resolved at card issuers HBOS & Lloyds.

Please accept our apologies for any inconvenience this external issue may have caused.

October 20, 2025 · 13:22 BST
Monitoring

We have been observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Visa card scheme with HBOS & Lloyds.

We have established this is occurring external to Judopay and we have notified via our channels to card issuers 3DS Authentication & Technology partners.

Please accept our apologies for any inconvenience this external issue may be causing.

October 20, 2025 · 13:08 BST
Monitoring

We have been observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication. This is resulting in a higher rate of failed authentication attempts with the majority seen on Visa card scheme with HBOS & Lloyds - likely related to todays widespread internet outage.

We have established this is occurring external to Judopay and we have notified via our channels to card issuers 3DS Authentication & Technology partners.

Please accept our apologies for any inconvenience this external issue may be causing.

October 20, 2025 · 09:46 BST

← Back