Transaction Failures Observed

Minor incident General Notifications
2025-10-23 12:07 BST · 4 hours, 13 minutes

Updates

Resolved

We have observed that payment authorisation performance has returned to normal levels, with a noticeable reduction in timeout errors (codes 150 and 151) previously affecting transactions routed via Barclays and Worldpay.

Judopay’s systems have remained fully operational throughout.

Our gateway provider has now confirmed they have implemented a fix and the issue has now been mitigated. They continue to monitor to ensure the issue id fully resolved.

We apologise for any inconvenience caused and appreciate your patience while our gateway partner completes their investigation.

October 23, 2025 · 16:18 BST
Monitoring

We have observed that payment authorisation performance has returned to normal levels, with a noticeable reduction in timeout errors (codes 150 and 151) previously affecting transactions routed via Barclays and Worldpay.

Judopay’s systems have remained fully operational throughout.

Our gateway provider has confirmed they are continuing to investigate the root cause, and we are awaiting formal confirmation that the issue has been fully resolved.

We apologise for any inconvenience caused and appreciate your patience while our gateway partner completes their investigation.

October 23, 2025 · 14:10 BST
Issue

We’re currently observing intermittent instability affecting some payment authorisations.

Impact: Some transactions may fail or take longer than expected to process.
The issue appears related to timeout errors (codes 150 and 151) mainly impacting transactions routed to Barclays and Worldpay.

Judopay’s systems remain remain fully operational.
have been.

Our gateway provider has confirmed they are actively investigating timeout errors

We apologise for any inconvenience this may cause and appreciate your patience while our gateway partner works to resolve the issue.

October 23, 2025 · 13:22 BST

← Back