Elevated Transaction Latency (Barclays Acquirer)
Minor incident
General Notifications
2025-11-05 12:30 GMT
· 4 hours, 23 minutes
Updates
Resolved
November 5, 2025 · 16:50 GMT
As of 15:30 GMT response times have returned to acceptable thresholds for transactions routed through to the Barclays acquirer on gateway JGW2.
Our gateway partner continues to monitor performance to ensure stability.
Judopay’s systems have remained fully operational throughout, however we would like to apologise for any inconvenience caused during this incident.
Issue
November 5, 2025 · 15:13 GMT
We are aware of increased transaction response times impacting processing through the Barclays acquirer on gateway JGW2.
Our gateway partner has identified the issue and is actively investigating. Judopay’s systems remain fully operational and are processing transactions as normal.
We will provide further updates as soon as more information becomes available.
← Back
Judopay's Status Page