3DS2 Authentication Failures Observed

Minor incident General Notifications
2025-11-18 14:58 GMT · 1 hour, 39 minutes

Updates

Resolved

We’ve received confirmation from our technical partners that the issue has now been fully resolved. 3DS2 challenge flows are operating as expected, and no further impact is observed.

We’ll continue to monitor, but no action is required at this time.

November 18, 2025 · 16:37 GMT
Monitoring

Currently we are observing that some card issuers are experiencing ongoing problems with processing 3D Secure 2 authentication challenge flows. This is resulting in a higher rate of failed authentication attempts with the majority seen on Visa/Mastercard.

We have established this is occurring external to Judopay and we are aware that this is actively being investigated by the card issuers 3DS Authentication & Technology partners - possible cause suggest this may be related to the ongoing global Cloudflare outage impacting multiple networks and services worldwide.

Please accept our apologies for any inconvenience this external issue may be causing.

November 18, 2025 · 12:00 GMT

← Back