Transaction Failures Observed
Updates
Investigating – Transaction Processing Issues
We are currently investigating an issue that may be affecting transaction processing, which could result in failed payment attempts for some users.
Our engineering team is actively investigating and working to resolve this as quickly as possible. We apologise for any inconvenience this may cause.
We will provide a further update within the next hour.
Resolved – Transaction Processing Restored
Issue Started : 16:01 BST
Issue Ended : 16:30 BST
Our engineers have successfully recovered the service and transactions are processing normally again. Engineers continue to monitor the service closely.
We will be conducting a full investigation into the root cause of this incident and will establish any necessary mitigating steps to prevent recurrence.
We apologise for any inconvenience caused and thank you for your patience.
← Back
Judopay's Status Page