Portal - Degraded Performance
Minor incident
General Notifications
Payment Services
Portal
2026-09-17 09:29 BST
· 5 hours, 48 minutes
Updates
Resolved
September 17, 2026 · 15:14 BST
This issue has now been resolved. The portal is back to normal performance and searches are no longer timing out as of 11am BST. We apologise for any inconvenience this may have caused and thank you for your patience.
Issue
September 17, 2026 · 09:29 BST
We’re currently experiencing degraded performance affecting the portal, and some searches may be timing out. Our engineering team is aware of the issue and actively investigating. We’ll share updates here as we learn more.
← Back
Judopay's Status Page