Portal Service Unavailable

Minor incident Payment Services Portal
2021-04-17 17:35 BST · 16 hours, 32 minutes

Updates

Resolved

Portal Service has now been re-enabled

November 4, 2021 · 15:25 BST
Monitoring

Judopay has temporarily removed portal access whilst we continue to monitor services.

November 4, 2021 · 15:25 BST

← Back