Intermittent Transaction Failures

Minor incident Judopay Announcements
2021-09-18 01:02 BST · 58 minutes, 35 seconds

Updates

Resolved

Transactions restored

September 18, 2021 · 02:00 BST
Issue

We are currently investigating an issue with one of our upstream GW providers JB1 / JGW2

September 18, 2021 · 01:02 BST

← Back